
1. UVOD U MACROMEDIA DREAMWEAVER
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1. prozor dokumenta (document window)
- u ovom prozoru se izrađuju web stranice na jednostavan način ubacivanja različitih elemenata 

2. insertna traka (insert bar) -umetanje elemenata na web stranicu 

3. „inspektor“ svojstava elemenata (property inspector)
- omogućava podešavanje izgleda i atributa elemenata na stranici (npr. veličina, lokacija i položaj slike, formati teksta – bold, italic...) 

4. grupe panela (panel groups)
- paneli koji su međusobno grupirani i koji omogućavaju brzi pregled i editiranje određenih elemenata na stranici (npr. Files paneli koji nam omogućava uvid u sve dokumente i mape određenog web sitea; pristupa se u izborniku Window – tipkovnička kratica F8) 
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2. Definiranje karakteristika web sjedišta (web site)

1. korak je definiranje web sjedišta (web site) u kojem se određuje lokacija svih dokumenata i mapa na računalu 
- Dreamweaver „pamti“ sve promjene koje radite na svojim dokumentima 

-   dvije metode definiranja web sjedišta: 

1. čarobnjak (wizard) i 

2. napredna metoda (advanced)  - ispuniti nekoliko bitnih postavki (naziv web site-a, odabir lokalne korijenske mape i odabir mape sa slikama)
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3.  opcije koje treba podesiti!!!

1. Odaberite u izborniku Edit > Preferences 
- otvorit će se dijaloški okvir koji u lijevom stupcu prikazuje listu svih kategorija i opcija podešavanja koje omogućavaju prilagođavanje programa osobnim zahtjevima i preferencijama 

2. Kliknite u listi kategorija na General, a u desnom stupcu označite slijedeće:
- kućicu kvačicom gdje piše “Use CSS instead of HTML tags ”
- označite „Centering: Use <div> tag “
- u polje „ Maximum number of history steps “ upišite 50 ili 100 
(korisno za opciju undo ukoliko se trebate vratiti nekoliko koraka unazad i ispraviti dokument) 

3. U listi kategorija odaberite Invisible Elements i tada označite kvačicom „Line Breaks“ 

4. U listi kategorija odaberite File types/editors, i odaberite program kojim ćete otvarati i editirati određenu vrstu dokumenta izravno iz Dreamweavera (npr. uobičajeno je da sve slike u .gif ili .jpg formatu otvaramo i uređujemo u grafičkim programima kao što su Adobe Photoshop ili Fireworks) 

5. U listi New Document  pod Default Document  odaberite HTML, pod Default Extension upišite .html, a pod Default Document Type (DTD) odaberite XHTML 1.0 Transitional 

6. U listi Preview in Browser odaberite internet preglednik i pripadajuću tipkovničku kraticu u kojem ćete lokalno pregledavati izgled web stranica (npr. tipkovnička kratica F12 će otvoriti trenutnu web stranicu u Internet Exploreru, a tipkovnička kratica Ctrl + F12 će otvoriti Firefox 

[image: image4.png]Legenda

Lista kategorija
(Category list)
2. Opcije (Options)





 Dijaloški okvir Preferences
 - otvorite:

1. Standarnu traka alata i traku alata dokumenta pomoću izbornika View > Toolbars > Standard i View > Toolbars > Document
2. inspektor svojstava (Property inspector) i insertnu traku (Insert bar) pomoću izbornika Window > Properties i Window > Insert 

3. Panelu stilskih listi (CSS styles) pomoću izbornika Window > CSS Styles, a panelu dokumenata (Files panel) pomoću izbornika Window > Files 

Nakon definiranja web site-a (web projekta) možete započeti sa izradom web stranice. 

4. Izrada web stranice u Dreamweaveru

1) File > New > Blank Page > HTML (Ctrl + N) 
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Dijaloški okvir novog dokumenta (New Document)

2) Nakon otvaranja novog HTML dokumenta potrebno je taj dokument spremiti na hard disk (File > Save As) unutar mape koju smo definirali kao lokalnu korijensku mapu 

- naziv HTML dokumenta:
* ekstenzija .htm, .html, slova (a-z), brojke (0-9), crticu (-) ili donju crticu (_)
** ne razmake ili specijalne simbole (&,%,/,?...)
*** glavni HTML dokument koji se prvi otvara - „index.html“  

3) Naslov HTML dokumenta

Kliknite u polje za unos naslova (Title box) koji se nalazi na vrhu prozora dokumenta i upišite naslov HTML dokumenta. 

4) Podešavanje osnovnih karakteristika web stranice

Page Properties - na Property inspector
ili odaberite izbornik Modify > Page Properties 
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Izbornik Modify > Page Properties
U dijaloškom okviru Page properties - odrediti osnovne karakteristike (svojstva) web stranice :
1. Izgled, veličina i boja pisma (Font)
2. Boja pozadine stranice (Background color)
3. Margine stranice (Left, Top, Bottom i Right Margin)
4. Veličina, boja i vrsta pisma za linkove
- 4 vrste stanja: normalno stanje – stanje prije klika na link (regular), posjećeno stanje – stanje nakon klika na link (visited), aktivno stanje – stanje u trenutku klika na link (active) i rollover stanje – stanje prilikom prelaska pokazivača preko linka 

5. Veličina, boja i vrsta pisma za tipove naslova, itd... 

[image: image7.png]Legenda

Page Properties

Kategorije dokumenta

(Page properties categor) | capry ==
2. tzgled (format) pismo | ErErTTE— ——
(Font appereance) [
s B
3. Siika podiage dokumentd (/- © E
(®ackground image) Tot ot T ]
4. Margine web stranice sesponieio [ .
(Page margins) © vmmrieen
s S





Page Properties

[image: image8]

[image: image9]

Tablice
· Insert – Table 

Ili panelom Insert i to pomoću dva taba (objekta, kartice) – Common i Tables . Na obje kartice nalazi se ikona Insert table koji otvara isti dijaloški prozor Table kao i akcija preko izbornika Insert – Table.
Kad želite ubaciti tablicu, poslužite se izbornikom Insert > Table. Pojavit će se dijalog kao na slici lijevo.

Ako radite tablicu za raspored elemenata stranice, tad pažljivo smislite koliko vam redaka i stupaca treba i zadajte to u polja Rows i Columns.

Zavisno od toga želite li tablicu fiksne širine ili da se tablica svojom širinom prilagođava širini prozora, zadajte širinu tablice u pikselima ili u postocima. 

U polju Border thickness biramo debljinu ruba, a pod Cell padding i Cell spacing namještamo razmak  između  teksta i ruba odnosno između ćelija.

Dok nam polje Header služi za naslove, pa tako možemo birati hoćemo li ih postaviti lijevo ,na vrh ili oboje. Pod Accessibility biramo naslov naše tablice te njegovo poravnanje. 
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Kad je tablica ubačena kliknite na neko polje u tablici i ispod dobivate traku Properties u kojoj birate daljnje opcije poput fonta, stila duljine i širine itd. 
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Ukoliko želite spajati pojedina polja ili razdvajati već spojena, poslužite se dvama malim ikonicama u lijevom donjem kutu Properties trake ispod natpisa Cell (naredbe Merge i Split Cells).
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· Dvokliknite sliku da bi se pojavio dijaloški okvir Select Image Source

· Dvokliknite sliku u panel Assets da biste pokrenuli editor slika

· Ako želite zamijeniti jednu sliku drugom, odvucite ikonu Point to File slika iz panela Properties na drugu datoteku slike


[image: image15]

[image: image16]

[image: image17]
· Mišem označite dio na slici koji želite da predstavlja referentni dio linka,taj dio bit će obrubljen i prekriven prozirno plavkastom bojom

· Panel Properties mijenja izgled i sad izgleda ovako:

· U novonastalom panelu se definira link: 

      a) u okvir Link upisujete putanju linka ili link stvorite gumbima Browse for File ili Point to File

      b) polje Target-gdje će se link otvarati

      c) polje Alt- alternativni tekst
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Povezivanje unutar dokumenta


Imenovanje točke na stranici:

· Otvorite dokument u koji želite umetnuti imenovano odredište. Klikom postavite točku unosa na željeno mjesto ili selektirajte entitet koji želite imenovati.

· U traci izbornika odaberite Insert > Named Anchor. Ili Iz panela Insert i kartice  Common odaberite ikonu Named Anchor.
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Format (1.) - padajući izbornik s opcijama za format texta 


Link (2.) - linija za upisivanje linka ili putanje (patha) do neke datoteke unutar definiranog sitea ili na računalu.


Browse for File (3.) - odabir datoteke pomoću prozora. 


Point to File (4.) - klik na gumb te tehnikom drag and drop do željene datoteke u panelu Files. 


Size (5.) - kombinirano polje koje sadrži popis brojeva koji predstavljaju veličinu slova. 


Target (6.) – padajući izbornik kojim odabiremo argument (atribut) za link koji smo prethodno definirali.


Color (7.) - boja teksta. 





Panel Properties, omogućuje rad s atributima objekata koje možemo staviti na stranicu. Ovaj panel otvaramo kao i sve ostale, iz izbornika Window. S obzirom da se često koristi moguće ga je otvoriti i iz izbornika Modify - Selection Properties. Izgled mijenja ovisno o selektiranom objektu. Kada odaberemo neki tekst, sadrži sljedeće opcije za oblikovanje teksta:��





Oblikovanje teksta panelom properties





Category Links





Link font: Vrsta fonta za linkove, neovisno o vrsti fonta na web stranici.�


Size: Veličina slova tekstualnog linka.�


Link color: Boja slova tekstualnog linka.�


Visited links: Boja slova linkova koje smo već posjetili.�


Rollover links: Boja slova linka kada mišem pređem preko njega. �


Active links: Boja slova aktivnog linka.�


Underline style: Način pocrtavanja linka.





U ovom prozoru imamo pet kategorija. 





Category-kroz koje možemo podesiti opcije za stranicu.�


Page font: Razmislite kako će biti prikazan vaš font na računalo koje nema ”snimljen” taj font. 





Pretraživač (Browser) će odabrati po imenu najsličniji.�


Size: Veličinu slova možete odrediti: u pixelima ili u odnosu na veličinu koju je korisnik podesio u svom pretraživaču 





Text color: Boja slova�


Background color: Pozadinska boja tablica se posebno određuje.�


Background image: Ako je pozadinska slika manja od vidljivosti na ekranu onda se automatski ponavlja.�


Margin: Možemo odrediti mjernu jedinicu.��





Apearance(Izgled)





Links(Linkovi)





INSERT > IMAGE ili kliknite gumb IMAGE na kartici COMMON alatne trake INSERT ili pritisnite Ctrl+Alt+I; U sva 3 slučaja pojavit će se dijaloški okvir Select Image Source


Ako znate lokaciju slike na Webu ili na vašem računalu, otipkajte je u okvir URL ili pretražite datoteke i mape na računalu dok ne pronađete željenu datoteku slike; kliknite ikonu ili datoteku slike da bi se njeno ime pojavilo u okviru File name


Kliknite OK da biste zatvorili dijaloški okvir Select Image Source; slika će se pojaviti u prozoru dokumenta na mjestu određenom položajem točke unosa 


Dvokliknite sliku da bi se pojavio dijaloški okvir Select Image Source


Dvokliknite sliku u panel Assets da biste pokrenuli editor slika


Ako želite zamijeniti jednu sliku drugom, odvucite ikonu Point to File slika iz panela Properties na drugu datoteku slike








Umetanje slika





Dreamweaver nudi koristan alat za upravljanje slikama i drugim multimedijskim objektima koji se zove panel Assets


Da bi se u panelu Assets mogle pojaviti naše slike,moramo stvoriti lokalno sjedište s priručnom memorijom


Da bismo umetnuli sliku:


Otvorite lokalno sjedište (definirajte Web site) u kojem se nalaze slike odabirom njegovog imena u traci izbornika panela Site


Otvorite panel Assets odabirom WINDOW > ASSETS u traci izbornika (ili pritisnite F11); pojavit će se panel Assets


Kliknite gumb Images s lijeve strane panela Assets da biste prikazali slike


Da biste vidjeli pretpregled bilo koje slike u panelu Assets, kliknite na njezino ime,pojavit će se pretpregled slike


Da biste umetnuli selektiranu sliku, jednostavno je iz panela odvucite na stranicu; sliku možete umetnuti i klikom gumba Insert








Umetanje slika pomoću panela Assets





Sliku također možete pretvoriti u vezu


Da biste stvorili slikovnu vezu:


U stranici otvorenoj u prozoru dokumenta klikom selektirajte sliku koju želite pretvoriti u vezu


Po potrebi prikažite panel Properties


U okvir Link otipkajte lokaciju željenog odredišnog dokumenta


Pritisnite Enter


Vaša slika postati će povezana i moći ćete joj dodati rub veze:


Klikom selektirajte sliku


U okvir Border u proširenom panelu Properties otipkajte broj


Pritisnite Enter i rub će se pojaviti





Slikovne veze





U radu sa slikama često se javlja potreba da pojedini dijelovi jedne slike imaju različite veze


Opcija Map u Macromedia Dreamweaveru MX omogućava postavljanje veze unutar slike


Da biste otvorili mapiranu sliku:


Umetnite sliku na bilo koji način


Selektirajte sliku


U trenutku kada je slika selektirana u panel Properties se prikazuju dodatne opcije Map


Odaberite na panelu Properties jedan od oblika mapiranja (1.,2.,3.) kojim ćete od dijela slike stvoriti referentni dio linka,hotspot








Mapirane slike




















 forma će se pojaviti u obliku creveno iscrtkanog pravokutnika





 zatim odete u izbornik Insert te izaberete Form








 otvorite novu stranicu u Dreamweaweru       te ju postavite kako vam odgovara(visina, širina, boja, naslov itd.)





FORME





  zatim odaberite izbornik Insert > Form object > Radio Button nakon ćega će se pojaviti Radio button


 napišite svoj odgovor desno od Radio Button-a











 dajte naslov vašemu kvizu tako što ćete upisati tekst i postavite prvo pitanje, nakon toga držite Shift i Enter kako biste otišli u sljedeći red





umetanje radio button-a





3) Initial State mora obavezno biti namješteno na Unchecked





2) Unesite odgovor koji se odnosi na Radio Button  





1) Unesite naziv pitanja(npr. Question1 i koristite ga za svaki odgovor u tom pitanju)





 kliknite na Radio Button i odite u Properties Box(na slici) – ako Properties Box-a nema na ekranu odaberite izbornik Windows > Properties





 ponovite korake od 2-4 za svaki odgovor u određenom pitanju





 unutar zagrade napišete npr. točno ili netočno, ovisno o odg.





  prije zadnje > na označenom dijelu koda upišite:  onclick="alert(' ')" 


[kod bi trebao izgledati ovako: <input type="radio" name="Question1"     value="True" onclick="alert(' ')">]





 kliknite na Radio Button da bi odgovarajući redak u HTML kodu bio označen





Stvaranje veza:


Da biste umetnuli veze dovoljan je samo uvijek koristan panel Properties.


Da biste stvorili tekstualnu vezu:


U stranici otvorenoj u prozoru dokumenta selektirajte tekst koji želite pretvoriti u vezu.


U panelu Properties u okvir Link otipkajte (ili zalijepite naredbom Paste prethodno kopiranu iz Address bara) lokaciju odredišnog dokumenta.


Pritisnite Enter.     





Vrste veza:


Apsolutne putanje. (vode na lokaciju na Internetu izvan sjedišta u kojemu se nalazi trenutačna stranica). 


Putanje relativne u odnosu na dokument. (vode od trenutačne stranice do drugog dokumenta u istom sjedištu tako što koriste točke i kose crte da bi kazale pretraživaču kada mora pogledati u drugu mapu da bi pronašao stranicu). 


Putanje relativne u odnosu na korijensku mapu sjedišta. (vode od trenutačnog dokumenta do drugog dokumenta koji se nalazi unutar istog sjedišta). 


Imenovana odredišta. (vode do određene točke na stranici; ili na drugoj stranici).





Vrste veza i stvaranje veza




















Da biste otkrili o kojem je nevidljivom elementu riječ, kliknite njegovu ikonu i u panelu Properties će se pojaviti njegova svojstva.


Da biste stvorili vezu koja vodi do imenovanog odredišta:


U prozoru dokumenta selektirajte tekst ili sliku koju želite koristiti kao vezu.


U okvir Link u panelu Properties otipkajte znak povisilice (#).


Bez razmaka iza znaka povisilice u okvir Link otipkajte ime odredišta. Primjerice, ako je ime vašeg odredišta - vrh, u okvir Link trebali biste otipkati #vrh.�Ili koristite gumb Point to File.


Pritisnite Enter i vaš će se tekst ili slika povezati s imenovanim odredištem. ��   











Pojavit će se dijaloški okvir Named Anchor:




















Otipkajte ime odredišta u okvir Anchor Name. Ime bi, zbog jednostavnosti, trebalo biti jedna riječ napisana malim slovima ili broj; nemojte koristiti razmake.


Kliknite OK da biste zatvorili dijaloški okvir Named Anchor i vratili se u prozor dokumenta.


        Prikaz nevidljivih elemenata:


U traci izbornika odaberite View > Visual Aids > Invisible Elements.


Svi nevidljivi elementi na vašoj stranici pojavit će se u obliku ikona. ��     ��








Pojavit će se dijaloški okvir Email Link.




















Tekst selektiran u 1. koraku pojavit će se u okviru Text. Možete ga urediti ili ostaviti nepromijenjenog, a možete i otipkati novi tekst.


Otipkajte punu e-mail adresu u okvir E-mail.


Kliknite OK da biste zatvorili dijaloški okvir Email Link i umetnuli e-mail vezu. ��





            E-mail veza izgleda ovako:


<AHREF="mailto:dreamweaver@tarin.co"> pošalji poštu </A>


Možete ih umetati pomoću dijaloškog okvira ili panela Properties.


            Umetanje e-mail veze:


Selektirajte tekst koji želite pretvoriti u e-mail vezu ili jednostavno klikom postavite točku �unosa na mjesto gdje želite da se pojavi veza.


U traci izbornika odaberite Insert > Email Link.


ili u kartici Common alatne trake Insert kliknite gumb Email Link.


 





Povezivanje s e-mail adresom
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